Articles Tagged system requirements

PDF Impress 2014 and SlimPublisher 4.0 are Windows 8.1 certified

Both BinaryNow products, PDF Impress 2014 as well as SlimPublisher 4.0 passed Microsoft Windows 8.1 certification and are now listed in a Business software category in Windows 8.1 store. You will have to use…

Read more →

PDF Impress 2013 and SlimPublisher 3.1 are Windows 8 certified

Both BinaryNow products, PDF Impress 2013 as well as SlimPublisher 3.1 passed Microsoft Windows 8 certification and are now listed in Microsoft Windows 8 Compatibility Center. Additionally both these popular Desktop applications are…

Read more →