PDF Impress System Requirements

New 10 Version

Below are the minimum system requirements for PDF Impress 10:

Operating Systems

  • Windows® 10 (x86 and x64)
  • Windows® 8 (x86 and x64)
  • Windows® 7 (x86 and x64)
  • Windows® Vista (x86 and x64)
  • Windows® XP (x86)
  • Windows® Server 2003 (x86 and x64)
  • Windows® Server 2008 (x86 and x64)
  • Windows® Server 2012 (x64)
  • Windows® Terminal Services

Memory and Hard Drive Space

  • 512 MB of RAM for Windows XP/VISTA
  • 1GB (32-bit) or 2GB (64-bit) MB of RAM for Windows 7,8,10,2003,2008,2012
  • 250 MB of HD space for installation

Workroom, Convert to PDF and Watcher Requirements

  • Autodesk® AutoCAD 2007 or higher
  • Microsoft® Word 2002, 2003, 2007, 2010 or 2013
  • Microsoft® Excel 2002, 2003, 2007, 2010 or 2013
  • Microsoft® PowerPoint 2002, 2007, 2010 or 2013
  • Microsoft® Visio 2002, 2003, 2007, 2010 or 2013
  • Microsoft® Publisher 2002, 2003, 2007, 2010 or 2013
  • Microsoft® Internet Explorer 9.0+
  • OpenOffice.org 2.2+

Hardware (optional)

  • Scanner (TWAIN 1.8 or higher ) or Webcam
  • SafeNet eToken 5100 usb token or smartcard device